Error in request message: xp.get_tag() failed

Message boards : Number crunching : Error in request message: xp.get_tag() failed
Message board moderation

To post messages, you must log in.

AuthorMessage
Jacob Klein

Send message
Joined: 5 Nov 18
Posts: 4
Credit: 973
RAC: 0
Message 44 - Posted: 5 Nov 2018, 23:40:16 UTC
Last modified: 5 Nov 2018, 23:42:02 UTC

Hi,

I created an account, and then tried to attach BOINC 7.14.2 x64, on Windows 10 x64, to the project.
But I get an error -- Error in request message: xp.get_tag() failed -- (full details below), and then BOINC doesn't show my Account Name in the Advanced View. It shows as blank.

The sched_request_boinc.nanohub.org_nanoHUB_at_home.xml file looks like correctly formatted XML to me. Note I have 3 GPUs and an 8-core hyperthreaded CPU.

So what is the problem?

Note: I can send the sched_request_boinc.nanohub.org_nanoHUB_at_home.xml file separately if needed, since it may contain sensitive info. Just let me know.

From BOINC Error Log:
11/5/2018 6:35:05 PM |  | Fetching configuration file from https://boinc.nanohub.org/nanoHUB_at_home/get_project_config.php
11/5/2018 6:35:23 PM | nanoHUB_at_home | Master file download succeeded
11/5/2018 6:35:28 PM | nanoHUB_at_home | Sending scheduler request: Project initialization.
11/5/2018 6:35:28 PM | nanoHUB_at_home | Requesting new tasks for CPU and NVIDIA GPU
11/5/2018 6:35:30 PM | nanoHUB_at_home | Scheduler request completed: got 0 new tasks
11/5/2018 6:35:30 PM | nanoHUB_at_home | Error in request message: xp.get_tag() failed
11/5/2018 6:35:40 PM | nanoHUB_at_home | Sending scheduler request: To fetch work.
11/5/2018 6:35:40 PM | nanoHUB_at_home | Requesting new tasks for CPU and NVIDIA GPU
11/5/2018 6:35:41 PM | nanoHUB_at_home | Scheduler request completed: got 0 new tasks
11/5/2018 6:35:41 PM | nanoHUB_at_home | Error in request message: xp.get_tag() failed


From sched_reply_boinc.nanohub.org_nanoHUB_at_home.xml:
<scheduler_reply>
<scheduler_version>709</scheduler_version>
<master_url>https://boinc.nanohub.org/nanoHUB_at_home/</master_url>
<request_delay>7.000000</request_delay>
<message priority="low">Error in request message: xp.get_tag() failed </message>
<project_name>nanoHUB_at_home</project_name>
</scheduler_reply>
ID: 44 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Jacob Klein

Send message
Joined: 5 Nov 18
Posts: 4
Credit: 973
RAC: 0
Message 50 - Posted: 6 Nov 2018, 16:11:34 UTC

Admins:
Hmm... It seems to be working correctly now, without an error.
Did you fix/change something on your end?
ID: 50 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Contact
Avatar

Send message
Joined: 3 Jun 18
Posts: 6
Credit: 11,025
RAC: 14
Message 51 - Posted: 6 Nov 2018, 16:51:20 UTC

I can confirm that Error in request message: xp.get_tag() failed was reported in the logs recently but is no longer present.
ID: 51 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Nonexistent_Admin
Volunteer moderator
Project administrator

Send message
Joined: 27 Sep 18
Posts: 58
Credit: 0
RAC: 0
Message 53 - Posted: 6 Nov 2018, 19:38:03 UTC - in response to Message 50.  

No change on our end. Please let us know if it happens again.
ID: 53 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Jim1348

Send message
Joined: 11 Jan 17
Posts: 64
Credit: 194,081
RAC: 209
Message 54 - Posted: 7 Nov 2018, 13:40:37 UTC - in response to Message 53.  

I get "Error in request message: xp.get_tag() failed" also on both a Win7 64-bit machine (i7-4771) and an Ubuntu 16.04 machine (i7-3770) each time I request a work unit.
ID: 54 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Contact
Avatar

Send message
Joined: 3 Jun 18
Posts: 6
Credit: 11,025
RAC: 14
Message 55 - Posted: 8 Nov 2018, 12:14:23 UTC - in response to Message 54.  

Jim1348 wrote:
I get "Error in request message: xp.get_tag() failed" also
I wasn't getting that when this was posted 22 hours ago, but I'm getting it now on only one host and all good on two other very similar Win7 hosts.
Also the affected host lost account and team data for this project in the Projects tab of the manager.
ID: 55 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Jacob Klein

Send message
Joined: 5 Nov 18
Posts: 4
Credit: 973
RAC: 0
Message 56 - Posted: 8 Nov 2018, 13:37:12 UTC

Admins:
How can we help you to fix this problem?
ID: 56 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Nonexistent_Admin
Volunteer moderator
Project administrator

Send message
Joined: 27 Sep 18
Posts: 58
Credit: 0
RAC: 0
Message 57 - Posted: 8 Nov 2018, 15:43:23 UTC - in response to Message 56.  

If you encounter this error, please post the (UTC) time at which you encountered it. We are logging scheduler requests and replies on our side, trying to find the problem. It seems to be intermittent, possibly a network or firewall issue on our end. If we can correlate the bad requests/replies with our logs we hope to find the issue. David is working with us, too. Thanks for your help and patience.
ID: 57 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Contact
Avatar

Send message
Joined: 3 Jun 18
Posts: 6
Credit: 11,025
RAC: 14
Message 58 - Posted: 8 Nov 2018, 16:23:28 UTC

This host https://boinc.nanohub.org/nanoHUB_at_home/show_host_detail.php?hostid=453 shows the error. That page shows Last contact 9 Jun 2018 even after this attempted update with the manager.

08/11/2018 11:01:11 AM | nanoHUB_at_home | Error in request message: xp.get_tag() failed

That time stamp is EST, so 08/11/2018 6:01:11 AM UTC? I've tried a quick reset and detach and re-attach. Same error.
ID: 58 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Jim1348

Send message
Joined: 11 Jan 17
Posts: 64
Credit: 194,081
RAC: 209
Message 59 - Posted: 8 Nov 2018, 22:06:45 UTC - in response to Message 57.  

If you encounter this error, please post the (UTC) time at which you encountered it.

22:00 hours UTC on 8 November (today).

1924	nanoHUB_at_home	11/8/2018 5:00:53 PM	Error in request message: xp.get_tag() failed	
ID: 59 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Nonexistent_Admin
Volunteer moderator
Project administrator

Send message
Joined: 27 Sep 18
Posts: 58
Credit: 0
RAC: 0
Message 60 - Posted: 9 Nov 2018, 0:42:25 UTC

The project homepage contained some invalid configuration information. If you encounter this problem, please disconnect and reconnect to the project, to force your client to download the updated configuration info from the corrected homepage.
ID: 60 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Contact
Avatar

Send message
Joined: 3 Jun 18
Posts: 6
Credit: 11,025
RAC: 14
Message 62 - Posted: 9 Nov 2018, 1:44:48 UTC - in response to Message 60.  

Confirmed! Removing and re-attaching this project has fixed the problem with my affected host.
ID: 62 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
Jim1348

Send message
Joined: 11 Jan 17
Posts: 64
Credit: 194,081
RAC: 209
Message 63 - Posted: 9 Nov 2018, 14:10:59 UTC - in response to Message 60.  

Works for me too.
ID: 63 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
zombie67 [MM]
Avatar

Send message
Joined: 9 Feb 18
Posts: 3
Credit: 1,024,931
RAC: 0
Message 371 - Posted: 9 Jul 2019, 2:16:25 UTC
Last modified: 9 Jul 2019, 2:17:50 UTC

I am getting this problem now too. But only one of several hosts is having this problem.

Why is it happening again? It looks like the problem was fixed back in November?

I really don't want to detach/re-attach, as I have several hundred completed tasks on the host. Is there any other way to fix this?
Reno, Nevada
Team: SETI.USA
ID: 371 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote
zombie67 [MM]
Avatar

Send message
Joined: 9 Feb 18
Posts: 3
Credit: 1,024,931
RAC: 0
Message 372 - Posted: 9 Jul 2019, 17:13:17 UTC

I didn't want to wait any longer, and throw away even more hours. So I detached/re-attached. It is working properly now.

But I think there is still work to be done on the server to prevent this situation in the future.
Reno, Nevada
Team: SETI.USA
ID: 372 · Rating: 0 · rate: Rate + / Rate - Report as offensive     Reply Quote

Message boards : Number crunching : Error in request message: xp.get_tag() failed


©2020 COPYRIGHT 2017-2018 NCN